Why do I get a .NET error when installing the JAI SDK on Windows 10?

To use JAI SDK 2.1.6 or earlier versions, dotNET Framework 3.5 (or earlier) is needed.

On Windows 7 and Windows Vista, the components are installed by default.

On Windows 8 and Windows 10, the package must be installed. It can be downloaded automatically.

During installation, it is essential to keep your PC connected to the Internet. If not, you will see the error below:

err1.png

Please also refer to:

https://support.microsoft.com/en-au/help/2734782/.net-framework-3.5-installation-error-0x800f0906,-0x800f081f,-0x800f0907

※If connecting to Internet is not possible, please have your OS installation media ready. Usually this is a DVD, and you will have to insert the disk into your PC.

To manually install the package on Windows 10, these two steps can be performed:

  • Copy the "sources" folder from the Windows 10 DVD to the C drive on your PC.
  • Run this command in a CMD shell:
    • DISM /Image:C:\test\offline /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:C:\sources\sxs

JAI recommends using SDK 3.0 or later.

 

Products: JAI SDK 2.1.6 and earlier, running on Windows 8 and Windows 10.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.